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Editing HTML in Dreamweaver

Although Macromedia Dreamweaver allows you to create and edit Web pages 
visually without worrying about the HTML source code, there are times 
when you may need access to your page’s underlying HTML. Being able to 
edit the HTML can provide you with more control to modify and troubleshoot 
your Web page.

For example, suppose you select text on your document and apply a new font, but 
it only affects half the sentence. By looking at the HTML code in Dreamweaver 
Code view (or Code inspector), you discover that the closing </font> tag is in the 
middle of the sentence; all you have to do is move </font> to the end of your 
sentence and the problem is fixed. 

If you are interested in learning HTML, using the Dreamweaver visual editing 
capabilities along with its Code view (or Code inspector) is a great way to 
understand how HTML works. You can compare the HTML code to the visual 
view to see how it corresponds.

Dreamweaver provides access to the HTML code through the Code view, the 
Code inspector, and the Quick Tag Editor. For help in understanding and writing 
HTML code, use the Dreamweaver Reference panel.

Dreamweaver also gives you the ability to open HTML files written elsewhere 
without worrying about your code being compromised. Dreamweaver uses 
Roundtrip HTML to make sure your HTML content and structure do not 
change as you switch back and forth between Dreamweaver and an external 
HTML editor. In addition, you can use Dreamweaver to clean up HTML files 
that contain messy or unreadable code. 
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Understanding basic HTML tags
It can be useful to have a basic understanding of HTML when using 
Dreamweaver. You can easily see both the HTML code and the visual design at 
the same time, which gives you the opportunity to figure out how HTML code 
works. Understanding and being able to modify the code can help you 
troubleshoot your Web pages. If you are new to HTML, the following 
explanations provide a brief overview. If you already know HTML, skip ahead 
to the next section.

HTML is a text markup language. This means that HTML documents are plain 
text documents that have specific “markup” tags that tell the Web browser how to 
display the text. 

For example, the i tag controls italic text. By placing <i> in your HTML, you tell 
the browser that the subsequent text should be italic. By placing </i> in your 
HTML, you tell the browser that the subsequent text should revert to the default 
text. The tag with a slash (/) is called the closing tag.

Web browsers interpret these tags in your HTML document and display the text 
with the proper formatting. Some tags have attributes that you can use with them. 
For example, you can specify the alignment of an image within the image tag: 
<IMG SRC="image.gif" align="left">. align is an attribute of the image tag.

Structure of a document

Every HTML document (Web page) must contain certain standard tags—the 
head tag and body tag. The head section contains the title of the Web page (and 
any scripts), and the body section contains the actual text that will appear in the 
Web page as it is displayed in the browser.

Here is the structure of a sample document: 

<html>
<head>
<title>Title goes here</title>
</head>
<body>
<center>
<p>
<font size=+2>Welcome to my page</font>
</p>
<p>
The p is a paragraph tag, which tells the browser that this is all 
one paragraph.
</p>
</center>
</body>
</html>
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The required tags for every HTML document are html, head, and body.

Head tags

The head section (surrounded by head tags) contains only the page title 
(surrounded by title tags) and programming scripts, such as JavaScript code that 
implements an image rollover in your page.

The text that you put between <title> and </title> will appear in the top title 
bar of the browser window. It will not appear on the page.

For example, the following HTML results in the page shown below: 

<html>
<head>

<title>Purcy the cat</title>
</head>
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Body tags

The body of your document contains the content of your page. All your text, 
images, tables, and other content must be placed between <body> and </body>.

<html>
<head>

<title>Purcy the cat</title>
</head>
<body>
<center>

<h2>
Welcome to my home page.
</h2>
<p>
I am a two-year-old part Siamese cat who lives in 
San Francisco with my two owners.
</p>
<br>
<img src="cat.gif" width="400" height="250” align=”center”>
<br>
<p>
I like to eat all kinds of food, especially cheese.
</p>

</center>
</body>
</html>

All of the tags in the body section of the example can be used to format your content. 
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Heading tags—that is, h1 through h6 tags—mark the text as headings. Headings 
are typically displayed in the Web page with larger or bolder text than normal 
body text; h1 is the largest and h6 is the smallest. You always need the opening tag 
in front of your content, followed by the closing tag at the end of the content, as 
in this example: 

<h1> This is a heading 1</h1>

Paragraph tags (p) separate your text content into paragraphs. Because Web 
browsers wrap lines and ignore carriage returns, you must use p tags to prevent 
browsers from running all your text content together. The p tag adds extra white 
space between lines. You always need the opening tag in front of your paragraph 
content, followed by the closing tag at the end of the content, as in this example:

<p>
I am a two-year-old Siamese cat who lives in San Francisco with my 
two owners.
</p>

<p>
I like to eat all kinds of food, especially cheese.
</p>

Line break tags (br) force line breaks in your page, rather than adding extra white 
space like the paragraph tag. Because the br tag inserts a single line break, you do 
not need to include a closing tag.

Line break tags

Space created 
by line breaks
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Image tags insert images in your page. An image tag follows the format 
<img src="imagefilename">; you must put the file name of the image between 
quotation marks. Image tags also have attributes that you can use, such as width, 
height, border, align, and valign. The width and height attributes specify 
the size of your image for the Web browser to interpret; you can set the border 
width to 0 or above (images display a border by default when used as links). The 
align and valign attributes set alignment of your image: align (for horizontal 
alignment) can be set to left, right, or center, and valign (vertical alignment) 
can be set to top, bottom, or middle.

The following example shows a complete image tag:

<img src="cat.gif" width="400" height="250” align=”center”>

Text formatting tags

You can use HTML source code to format the text in your Web page. For 
example, you can specify text to be bold or italic and display in a particular font:

<b>This text will appear bold in the Web page</b>.
<i>This text will appear italic in the Web page</i>.
<font face=”verdana” size=”2”>This text will display with the 
Verdana font face and will be larger than the other text.</font>
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Inserting comments
A comment is descriptive text that you insert in the HTML code to explain the 
code or provide other information. The comment appears only in the Code view 
(or Code inspector), and will not display in your Web page in the browser. 

To insert a comment:

1 Place the insertion point where you want the comment, either in the Code 
view (or Code inspector) or Design view. 

See “Using the Code view (or Code inspector)” on page 330.

2 Click the Comment button in the Invisibles category of the Objects panel, or 
choose Insert > Invisible Tags > Comment. 

Creating a comment generates the following HTML code:

<!-- Comment text-->

To display comment markers in the Design view, choose View > Visual Aids > 
Invisible Elements. Make sure that comments are selected in the Invisible 
Elements preferences, or the comment marker will not appear. For more 
information, see “Setting Invisible Elements preferences” on page 156.

To add to an existing comment, do one of the following:

• Select the Comments marker in the Design view and enter text in the 
Property inspector.

• Find the comment in the code (see earlier example) and add text directly to it. 
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Using the Dreamweaver Reference panel
The Reference panel provides you with a quick reference tool for HTML tags, 
JavaScript objects, and CSS styles and their attributes. The Reference panel 
provides you with information regarding the specific tags, objects, or styles that 
you are working with in the Code view (or Code inspector). 

To open the Reference panel:

1 Select the tag, object, or style in the Code or Design view that you want 
information about.

2 Click the Reference button in the toolbar (View > Toolbar) or choose 
Window > Reference. 

The Reference panel opens, displaying information about the tag, object, or style that 
you selected. To adjust the text size in the Reference panel, select Large Font, Medium 
Font, or Small Font from the options menu (small arrow at top-right of panel).

The Book pop-up menu displays the name of the book that the reference material 
comes from: The O’Reilly HTML Reference, JavaScript Reference, or CSS 
Reference. To display tags, objects, or styles from another book, choose a book 
from the Book menu. 
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The Tag, Object, or Style (depending on which book you have selected) pop-up 
menu displays the tag, object, or style that you selected in the Code view (or Code 
inspector). To view information about another tag, object, or style, select a new 
one from the menu.

Next to the Tag, Object, or Style pop-up menu is a menu that contains the list of 
attributes for the tag you choose. The default selection is Description, which 
displays a description of the chosen tag. You can also select an attribute from the 
menu to view more information about it. Attributes are used to format the 
content in the tag. For example, you can use the align attribute to specify the 
alignment of an image within the image tag: <img src="image.gif" 
align="left">. 

About Roundtrip HTML
Roundtrip HTML is a unique feature in Dreamweaver that lets you move your 
documents back and forth between a text-based HTML editor and Dreamweaver 
with little or no effect on the content and structure of the document’s original 
HTML source code. Dreamweaver even maintains and renders some HTML that 
is technically invalid (such as a font tag enclosing multiple p tags) if such code is 
supported by browsers. However, the HTML source code that Dreamweaver 
generates as you edit graphically is always technically valid.

The following are key features of Roundtrip HTML:

• By default, Dreamweaver rewrites overlapping tags, closes open tags that aren’t 
allowed to remain open, and removes extra closing tags when you switch back to 
Dreamweaver from an external HTML editor or when you open an existing 
HTML document. If you don’t want Dreamweaver to rewrite any HTML, 
choose Edit > Preferences, then select Code Rewriting to turn off all rewriting. See 
“Setting Code Rewriting preferences” on page 346. If you turn off code rewriting, 
any HTML that Dreamweaver would have rewritten is displayed as invalid. 

• When Highlight Invalid HTML is turned on, Dreamweaver highlights invalid 
HTML (that it does not support) in yellow. When you select an invalid tag, 
Dreamweaver displays information in the Property inspector about how to 
correct the error. Highlight Invalid HTML is turned on by default in the Code 
view (or Code inspector). To turn it off, choose Highlight Invalid HTML from 
the Options menu in the Code view (or Code inspector) window. Error 
highlighting is always on in the Design view.

Note: Enable/Disable Invalid HTML Highlighting is only available in the Code view (or 
Code inspector). Design view always displays error highlighting.
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• Dreamweaver does not change tags that it does not recognize—including XML 
tags—because it has no criteria by which to judge them valid or invalid. If an 
unrecognizable tag overlaps a valid one, Dreamweaver may mark it as erroneous 
but does not rewrite the code. For example, the custom tag in the following 
would be marked erroneous: <MyNewTag><b>text</MyNewTag></b>.

• Dreamweaver does not alter ColdFusion Markup Language (CFML) or 
Microsoft Active Server Pages (ASP) tags, and it displays icons to identify 
blocks of CFML or ASP code in the Document window whenever possible. See 
“Editing ColdFusion and Active Server files in Dreamweaver” on page 352.

• Dreamweaver lets you launch a text-based HTML editor to edit the current 
document. Dreamweaver is integrated with HomeSite (Windows) and BBEdit 
(Macintosh). See “Using external HTML editors” on page 350.

Using the Code view (or Code inspector)
You can view the HTML source code for the current document in several ways: 
you can display only the Code view in the Document window, you can split the 
Document window so that it displays both the Code view and the Design view, or 
you can open the Code inspector. The Code view and the Code inspector work in 
exactly the same way; the only difference is that the Code inspector is in a separate 
window. Splitting the Document window to view the code makes it easier to view 
the visual design while you make changes in the HTML code.

As you add or change content in the Design view, Dreamweaver immediately 
displays the changes in the Code view or inspector. This makes the Code view or 
inspector a useful tool for learning HTML if you don’t already know it, or for 
reminding yourself of proper syntax or values for specific tags or attributes. HTML 
tags and scripts are color coded and can be adjusted in the preference settings. 

Changes or additions that you make in the code appear in the Design view only 
after you synchronize the Code and Design views. 

To synchronize the Code and Design views:

Click in the Design view after working in a code editor or click the Refresh Design 
view button in the toolbar. (Choose View > Toolbar to display the toolbar.) 

Dreamweaver never rewrites HTML that you type directly into a code editor. If 
you enter invalid code and Highlight Invalid HTML is turned on, Dreamweaver 
highlights the invalid code in the code editor. Error highlighting is on by default 
in the code editors. Error highlighting always appears in the Design view, even 
when Highlight Invalid HTML is turned off in the Code view.
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Opening the Code view (or Code inspector)

You can view the HTML source code in several ways: by displaying both code and 
design in the Document window, by displaying code only, and by opening the 
Code inspector.

To display both the Code and Design views:

Choose View > Code and Design, or click the Show Code and Design Views 
button on the toolbar. 

The HTML code appears in the top pane, and the Design view appears in 
the bottom pane. 

You can adjust the size of the panes by dragging the splitter bar.
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To adjust the split Code and Design view, do one of the following:

• To display the Design view on top, choose View > Design View on Top. 
Alternatively, select Design View on Top from the Options pop-up menu 
in the toolbar.

• To view only HTML code in the Document window, choose View > Code or 
click the Show Code View button in the toolbar.

• To view only the visual design, choose View > Design or click the Show Design 
View button in the toolbar.

If you prefer to work with the HTML code in a separate window, use the Code 
inspector to view your code.

To open the Code inspector, do one of the following:

• Choose Window > Code inspector.

• Click the Code Inspector icon in the Launcher bar (in the lower right corner of 
the Document window).

• Press F10.

To toggle between the Document window and the Code inspector:

Press Control-Tab (Windows) or Option-Tab (Macintosh). 
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Setting Code view (or Code inspector) options

You can set word wrapping, code indenting, syntax coloring and more from the 
Options menu in the code editors.

To access the Options menu, the Code view (or Code inspector) must be active. 
Click in the Code view (or Code inspector) to make it active.

To set Code view (or Code inspector) options:

1 Access the options by doing one of the following:

• Click the Options pop-up menu in the toolbar. (Choose View > Toolbar to 
view the toolbar.)

• Choose View > Code View Options. 

The options menu is also available at the top of the Code inspector.

2 Set the options you want:

• Line Wrap wraps the code so that is viewable without horizontal scrolling. This 
setting does not insert line breaks, but makes the code easier to view.

• Line Numbers adds line numbers along the side.

• Highlight Invalid HTML turns on error highlighting. When Highlight Invalid 
HTML is turned on, Dreamweaver highlights invalid HTML (that it does not 
support) in yellow. When you select an invalid tag, Dreamweaver displays 
information in the Property inspector about how to correct the error.

• Syntax Coloring marks the different parts of your code with colors so that you 
can quickly determine the different code elements. To change the colors, see 
“Setting Code Colors preferences” on page 343.

• Auto Indent makes your code indent automatically. To change the indent 
spacing or tags that automatically indent, see “Setting Code Format 
preferences” on page 344.
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Writing and editing code

As you write and edit your code in the Code view (or Code inspector), you can 
indent specific lines of code or check to make sure your tags are balanced. 
Indenting a specific line or section of code will help you separate that code from 
the rest, making it easier to find. Checking to see if your tags are balanced will 
help you ensure that all the tags have matching opening tags and closing tags, and 
is especially useful when you use multiple nesting levels in your code—for 
example, if you have nested several tables within other tables.

To indent selected code:

1 Select the line or lines of code you want to indent. 

For indenting to work, the whole line must be selected.

2 Choose Edit > Indent Code.

The code will be indented. Choose Edit > Outdent Code to move indented 
code back.

To check for balanced tags:

1 Place the insertion point in the nested code you want to check.

2 Choose Edit > Select Parent Tag. 

The enclosing matching tags will be highlighted in your code. Choosing Edit > 
Select Parent Tag again will highlight the matching tags that enclosed the 
previous selection.
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Inserting scripts
You can write or insert scripts in the Code view (or Code inspector), or you can 
enter JavaScript and VBScript in the Design view without having to use the Code 
view. You can also open script files in Dreamweaver Code view. Dreamweaver does 
not alter or rewrite the file. For more information, see “Opening and editing non-
HTML files in Dreamweaver” on page 338.

To display script markers in the Document window, choose View > Visual Aids > 
Invisible Elements. (See also “Setting Invisible Elements preferences” on page 156.) 

To insert a script in code or Design view:

1 Place the insertion point where you want the script.

2 Click the Script button on the Objects panel, or choose Insert > 
Invisible Tags > Script.

3 In the dialog box that appears, choose the scripting language from the 
Language pop-up menu.

If you are using JavaScript and are unsure of the version, choose JavaScript 
rather than JavaScript1.1 or JavaScript1.2. 

4 Enter your script code in the Content text box. 

To link to an external script file:

1 Follow steps 1 through 3 above. 

2 Click OK without typing anything in the Content text box.

3 Select the script marker in the Design view of the Document window. 

Choose View > Visual Aids > Invisible Elements to view the marker. Make sure 
that scripts are selected in Invisible Elements preferences, or the script marker 
will not appear. For more information, see “Setting Invisible Elements 
preferences” on page 156.

4 In the Property inspector, click the folder icon to browse to and select the 
external script file, or type the file name in the Source box.
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Editing a script

You can edit a script in a code editor or the Design view.

To edit the script in the Code view:

Find the script in the Code view and edit it directly. Selecting the Script marker in 
the design view will highlight the script in the code view.

To edit the script in the Design view:

1 Select the Script marker.

2 In the Property inspector, click the Edit button. 

If you linked to an external script file, the file automatically opens in Code view, 
where you can make your edits. Otherwise, the Script Properties dialog box opens 
and you can edit the script in the Script text box. 

Note: If there is code between the script tags, the Script Properties dialog box will open, 
even if there is also a link to an external script file.

The following properties appear in the Script Properties dialog box (and the 
Property inspector) when a script marker is selected:

• Language specifies either JavaScript or VBScript as the language of the script.

• Type specifies the type of script, either client-side or server-side.

• Source specifies an externally linked script file. Click the folder icon to choose 
the file, or type the path.

• Script is where you edit/write your script.
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To check for balanced braces:

1 Place the insertion point in the nested code you want to check.

2 Choose Edit > Balance Braces. 

The enclosing matching tags are highlighted in your code. Choosing Edit > 
Balance Braces again will highlight the matching tags that enclosed the 
previous selection.

Viewing script functions

You can view all of the JavaScript or VB Script functions in your code from the 
Code Navigation pop-up menu in the toolbar (View > Toolbar).

To view the script functions:

Click the Code Navigation button in the toolbar. 

If your code contains JavaScript or VB Script functions, they will appear in the 
menu. To see the functions listed in alphabetical order, hold down Control 
(Windows) or Option (Macintosh) while clicking the Code Navigation button.

To go to a function in your code:

Select a function from the Code Navigation pop-up menu. The function will be 
highlighted in the Code view (or Code inspector).
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Opening and editing non-HTML files in 
Dreamweaver
When you open a non-HTML file (for example, a .js file) in Dreamweaver, 
Dreamweaver does not alter it. These files open in the Code view (or Code 
inspector), with the Design view disabled. You can edit the file and save it as an 
HTML file or a non-HTML file.

You can set Dreamweaver to automatically open non-HTML files with certain 
extensions by default. For example, you can set the default preferences so that .js 
files automatically open in the Code view (or Code inspector).

To set the default preferences for non-HTML files:

1 Choose Edit > Preferences, then select File Types/Editors.

2 In the Open in Code View field, type the file name extensions you want to 
open automatically in Code view. Put a space between each file type.

The default file extensions listed are .js, .txt, and .asa. You can add as 
many as you want.

Editing an HTML tag in the Design view
Use the Quick Tag Editor to quickly inspect and edit the HTML source of a single 
tag from within the Design view, without having to switch to the Code view and 
back again. The easiest way to open the Quick Tag Editor is to press Control+T 
(Windows) or Command+T (Macintosh).

The Quick Tag Editor has three modes: 

• Insert HTML, used to insert new HTML code 

• Edit Tag, used to edit an existing tag 

• Wrap Tag, used to wrap a new tag around the current selection 

The current selection in the Design view determines the mode in which the 
Quick Tag Editor opens. In all three modes, the basic operation of the Quick Tag 
Editor is the same: you open the editor, enter or edit tags and attributes, and then 
close the editor.

If you use any invalid HTML in the Quick Tag Editor, Dreamweaver attempts 
to correct it for you by inserting closing quotation marks and closing angle 
brackets where needed.

To perform more extensive HTML editing, use the Code view (or Code inspector).
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To open the Quick Tag editor in Insert HTML mode:

1 Click in the Design view to place the insertion point where you want 
to insert code.

2 Press Control+T (Windows) or Command+T (Macintosh), or click the 
Quick Tag Editor button in the Property inspector. 

The Quick Tag Editor opens.

3 Enter the HTML tag, then press Enter. 

The tag is inserted into your code. Press Esc to exit without making any changes.

To open the Quick Tag editor in Edit Tag mode:

1 Select the text or object that you are editing in the Design view. 

You can also select the tag you want to edit from the tag selector at the bottom 
of the Document window.

2 Press Control+T (Windows) or Command+T (Macintosh), or click the Quick 
Tag Editor button in the Property inspector. 

The Quick Tag Editor opens.

3 Enter new attributes, edit existing attributes, or edit the tag’s name; 
then press Enter.

The edited tag is inserted into your code. Press Esc to exit without 
making any changes.
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To open the Quick Tag Editor in Wrap Tag mode:

1 Select unformatted text or an object. 

If you select text or an object that includes an opening or closing HTML tag, 
the Quick Tag Editor will open in Edit Tag mode.

2 Press Control+T (Windows) or Command+T (Macintosh), or click the Quick 
Tag Editor button in the Property inspector. 

The Quick Tag Editor opens.

3 Enter a single opening tag, such as <font="verdana">, and press Enter.

The tag is inserted at the beginning of the current selection, and a matching 
closing tag is inserted at the end. Press Esc to exit without making any changes.

To apply your changes immediately:

After editing a tag, press Tab or Shift+Tab. The change you made is applied 
immediately, rather than when you exit the Quick Tag Editor.

If you want to prevent this behavior, deselect the Apply Changes Immediately 
While Editing option in Quick Tag Editor preferences. (See “Setting Quick Tag 
Editor preferences” on page 342.)

Note: When the Apply Changes Immediately While Editing option is deselected, multiple 
changes that you apply at once appear as a single step in the History panel and are undone 
with a single Undo operation.

To cycle through the Quick Tag Editor modes:

With the Quick Tag Editor active, press Control+T (Windows) or Command+T 
(Macintosh).

The Quick Tag Editor changes modes each time you use the keyboard shortcut, 
cycling among Insert HTML mode, Edit Tag mode, and Wrap Tag mode.

To move the Quick Tag Editor on the screen:

Drag the editor’s handle (where the mode name appears).
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Using the hints menu

While in the Quick Tag Editor, you can access an attributes hint menu that lists all 
the valid attributes of the tag you are editing or inserting. (If Dreamweaver doesn’t 
recognize the tag you’re editing, the hints menu contains all the attributes that 
Dreamweaver recognizes for any tag.) The hints menu does not appear if you 
deselected the Enable Tag Hints option in Quick Tag Editor preferences.

To see a list of valid attributes for a tag you’re editing:

Pause for a few seconds while editing an attribute name. A hints menu appears, 
listing all the valid attributes for the tag you’re editing. Control the hints menu in 
the following ways:

• As you begin to type an attribute name, the hints menu scrolls to highlight the 
first attribute name that starts with the letters you’ve typed. 

• To move the highlighting up and down in the menu, use the Up and Down 
Arrow keys or the scroll bar.

• To choose the highlighted attribute name, press Enter (Windows) or Return 
(Macintosh). Alternatively, double-click an attribute name in the menu.

• To dismiss the hints menu without selecting an entry, press Esc or simply 
continue typing.

When you pause while entering or editing a tag name, a similar hints menu 
appears, listing tag names instead of attribute names.

The tags and attributes that the hints menu displays come from the 
TagAttributeList.txt file, located in your Dreamweaver/Configuration folder. If 
you’re an advanced Dreamweaver user and you want to add tags to or remove tags 
from the hints menu, you can edit this file. (See “Opening and editing non-
HTML files in Dreamweaver” on page 338.)

To edit existing attribute values in Edit Tag mode:

Press Tab to move forward from one item to the next, until the attribute (or tag) 
that you want to edit is selected. Press Shift+Tab to move backward to the 
previous attribute name, attribute value, or tag name.
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To add a new attribute to a tag:

1 Use Tab, the arrow keys, and the Spacebar to move the insertion point to where 
you want to add an attribute. 

2 Type a valid attribute name for the tag. 

If you pause in typing, the hints menu appears.

Removing a tag

You can remove a tag from your document, leaving its content (if any) in place.

To remove a tag:

1 Do one of the following: 

• Select the tag in the tag selector at the bottom left of the Document window. 

• Select anything in the Document window, or click to place the insertion point 
in the window. 

2 Right mouse-click (Windows) or Control-click (Macintosh) in the Design 
view, and choose Remove Tag from the context menu.

Setting Quick Tag Editor preferences

Quick Tag Editor preferences let you control whether the edits you make in the 
Quick Tag Editor are automatically updated in the Document window. You can 
also adjust the controls for the hints menu. To display these preferences, choose 
Edit > Preferences and select Quick Tag Editor.

Apply Changes Immediately While Editing controls whether your Quick Tag 
Editor changes are automatically updated in your document as you move between 
attributes in Edit Tag mode. If you turn off this option, you must press Enter to 
apply your changes to the document. (This option is ignored in Insert HTML 
mode and in Wrap Tag mode; in those modes, you must always press Enter to 
apply your changes to the document.)

Enable Tag Hints controls whether the hints menu appears while you’re typing in 
the Quick Tag Editor. You can also adjust the length of the delay before the menu 
displays for the current attribute or tag.
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Setting code formatting preferences 
You can set the following preferences for formatting code in Dreamweaver:

• Code Colors preferences control how HTML tags (and the text between them) 
and scripts are color coded in the Code view or Code inspector. See “Setting 
Code Colors preferences” on page 343.

• Code Format preferences determine common code formatting options, such as 
line length and indentation. See “Setting Code Format preferences” on page 
344. These preferences provide a user interface for changing the 
SourceFormat.txt file.

• Code Rewriting preferences determine what changes, if any, Dreamweaver 
makes to your code when you open an HTML or script document. See 
“Setting Code Rewriting preferences” on page 346.

• Fonts/Encoding preferences let you specify the font in which your code appears 
in the Code view (or Code inspector). See “Setting Fonts/Encoding 
preferences” on page 89.

Finally, the SourceFormat.txt file (in the Dreamweaver/Configuration folder) 
provides precise specifications for formatting code. Editing this file in a text editor 
gives you the greatest degree of control over exactly how Dreamweaver writes code; 
you can change certain tag-specific options in this file that you can’t change using the 
Code Format preferences. However, do not edit this file unless you are an advanced 
Dreamweaver user or developer, because you may cause serious errors to your 
Dreamweaver program. See “Changing default HTML formatting” on page 530.

Setting Code Colors preferences

Use Code Colors preferences to control the background, text, tag, and reserved 
keyword colors in the Code view (or Code inspector). To work with these 
preferences, choose Edit > Preferences and select Code Colors.

Background specifies the background color of the Code view (or Code inspector). 
This color appears only when you click or type in the Code view or inspector. 

Text specifies the color of text that appears between tags. For example, in the 
code <b>some text</b>, the words “some text” appear in the specified text color, 
but the tags do not. To override the text color for a specific tag, select the Include 
Contents option.

Comments specifies the color for comment tags (<!-- -->) and their contents.

Tag Default specifies the color for all tags except comments. To override this color, 
set the Tag Specific option.

Reserved Keywords specifies the color for all reserved keywords. To override this 
color, set the Tag Specific option.
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Other Keywords specifies the color for all other keywords. To override this color, 
set the Tag Specific option.

Strings specifies the color for all strings in your code. To override this color, set the 
Tag Specific option.

Tag Specific allows you to override the other color settings by specifying colors 
for specific tags.

To set a color for a specific tag:

1 Select a tag in the Tag Specific box.

Shift-click to select adjacent tags. To select nonadjacent tags, Control-click 
(Windows) or Command-click (Macintosh). 

2 Click the radio button next to the color swatch at the bottom of the panel, and 
use one of these methods to choose a new color value:

• Click the color swatch and select a new color from the palette of browser-safe 
colors or the system color picker.

• In the text field next to the swatch, enter a hexadecimal value.

3 To color the text between the opening and closing tags, select Apply Color 
to Tag Contents.

Setting Code Format preferences

Use the following Code Format preferences to control code formatting such as 
indentation, line length, and the case of tag and attribute names. (For information 
on additional code formatting controls, see “Changing default HTML 
formatting” on page 530.) 

Note that all the preferences except Override Case Of affect only new documents 
and new additions to existing documents. That is, when you open a previously 
created HTML document, these formatting options are not applied to it; to 
reformat existing HTML documents, use the Apply Source Formatting command. 
(See “Formatting the HTML source code in existing documents” on page 348.)

Indent turns on indentation of all tags marked indent in the SourceFormat.txt 
file. See “Changing default HTML formatting” on page 530. 

Use specifies whether to indent using spaces or tabs.

Table Rows and Columns automatically indents tr and td tags to make table code 
easier to read. The Indent option must be selected for this option to work.

Frames and Framesets automatically indents frame and nested frameset tags to 
make frameset files easier to read. The Indent option must be selected for this 
option to work. 
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Indent Size determines the size of indents. The size is measured in spaces if Use is 
set to spaces, or in tabs if Use is set to tabs. 

Tab Size determines the size of tabs (measured in character spaces).

Automatic Wrapping adds “hard” returns once a line reaches the specified column 
width. (Note that Dreamweaver inserts hard returns only in places where they 
don’t change the appearance of the document in browsers, so some lines may 
remain longer than the Automatic Wrapping option specifies.) By contrast, the 
Wrap option in the Code view (or Code inspector) adds a “soft” return for lines 
that extend beyond the width of the window. 

Line Breaks specifies the type of remote server (Windows, Macintosh, or UNIX) 
that hosts your remote site. Choosing the correct type of line break characters 
ensures that your HTML source code appears correctly when viewed on the 
remote server. (Note that for FTP, this setting applies only to binary transfer 
mode; Dreamweaver ASCII transfer mode ignores this setting. If you download 
files using ASCII mode, Dreamweaver sets line breaks based on the operating 
system of your computer; if you upload files using ASCII mode, the line breaks 
are all set to CR LF.) This setting is also useful when you are working with an 
external text editor that recognizes only certain kinds of line breaks. For example, 
use CR LF (Windows) if Notepad is your external editor, and CR (Macintosh) if 
SimpleText is your external editor.

Case for Tags and Case for Attributes control the capitalization of tag and 
attribute names. These options are applied to tags and attributes that you insert or 
edit in the Document window, but they are not applied to the tags and attributes 
that you enter directly in the Code view (or Code inspector), or to the tags and 
attributes in a document when you open it (unless you also select one or both of 
the Override Case Of options). 

Override Case Of: Tags and Attributes specify whether to enforce your specified 
case options at all times, including when you open an existing HTML document. 
When you select one of these options, all tags or attributes in open documents are 
immediately converted to the specified case, as are all tags or attributes in each 
document you open from then on (until you deselect this option again). Tags or 
attributes you type in the Code view (or Code inspector) and the Quick Tag 
Editor are also converted to the specified case, as are tags or attributes you insert 
using the Objects panel. For example, if you want tag names always to be 
converted to lowercase, specify lowercase in Case for Tags, and then select the 
Override Case Of: Tags option. Then when you open a document that contains 
uppercase tag names, Dreamweaver converts them all to lowercase.

Centering specifies whether elements should be centered using div 
align="center" or center. Both are part of the HTML 4.0 Transitional 
specification, but center is supported by a wider range of browsers.
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Setting Code Rewriting preferences

Code Rewriting preferences determine what Dreamweaver does while opening 
HTML or script documents. (These preferences have no effect when you edit 
HTML or scripts in the Code view or Code inspector.) If you turn off these 
rewriting options, Dreamweaver displays invalid markup items in the Document 
window for HTML that it would have rewritten. If you are importing an HTML 
document from Microsoft Word, you can use the Clean Up Word HTML 
command to remove any unnecessary HTML code. For more information, see 
“Cleaning up Microsoft Word HTML” on page 348.

Fix Invalidly Nested and Unclosed Tags rewrites overlapping tags. For example, 
<b><i>text</b></i> is rewritten as <b><i>text</i></b>. This option also 
inserts closing quotation marks and closing brackets if they are missing. 

Remove Extra Closing Tags deletes closing tags that have no corresponding 
opening tag.

Warn When Fixing or Removing Tags displays a summary of technically invalid 
HTML that Dreamweaver attempted to correct. The summary notes the location 
of the problem (using line and column numbers) so that you can find the 
correction and ensure it is rendering as intended.

Never Rewrite HTML: In Files with Extensions allows you to prevent Dreamweaver 
from rewriting HTML in files with the specified file name extensions. This option 
is particularly useful for files that contain third-party tags (such as ASP tags). For 
more information, see “Avoiding rewriting third-party tags” on page 544.

The two Special Characters options allow you control over whether Dreamweaver 
encodes certain characters in certain contexts. In general, it’s best to leave these 
options selected unless your files contain certain third-party tags that use the 
characters in question. For more information on these options, see “Avoiding 
rewriting third-party tags” on page 544.
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Cleaning up HTML source code
Use the Clean Up HTML command to remove empty tags, combine nested font 
tags, and otherwise improve messy or unreadable HTML code.

To clean up HTML source code:

1 Open an existing document and choose Commands > Clean Up HTML.

2 In the dialog box that appears, select from the following options:

• Remove Empty Tags removes any tags that have no content between them. For 
example, <b></b> and <font color="FF0000"></font> are considered 
empty tags, but the <b> tag in <b>some text</b> is not.

• Remove Redundant Nested Tags removes all redundant instances of a tag. 
For example, in the code <b>This is what I <b>really</b> wanted to 
say </b>, the b tags surrounding the word “really” are redundant and would 
be removed.

• Remove Non-Dreamweaver HTML Comments removes all comments that 
were not inserted by Dreamweaver. For example, <!--begin body text--> 
would be removed, but <!-- #BeginEditable "doctitle" --> would not 
(because it is a Dreamweaver comment that marks the beginning of an editable 
region in a template).

• Remove Dreamweaver HTML Comments removes all comments that were 
inserted by Dreamweaver. For example, <!-- #BeginEditable "doctitle" 
--> would be removed, but <!--begin body text--> would not (because it 
is not a Dreamweaver comment). Removing Dreamweaver comments turns 
template-based documents into ordinary HTML documents and library items 
into normal HTML code (that is, they cannot be updated whenever the 
original template or library item changes).

• Remove Specific Tag(s) removes the tags specified in the adjacent text field. Use 
this option to remove custom tags inserted by other visual editors and other 
tags that you do not want to appear on your site (for example, blink). Separate 
multiple tags with commas (for example, font, blink).

• Combine Nested <font> Tags When Possible consolidates two or more 
font tags when they control the same range of text. For example, <font 
size="7"><font color="#FF0000">big red</font></font> would be 
changed to <font font="7" font="#FF0000">big red</font>.

• Show Log on Completion displays an alert box with details about the changes 
made to the document as soon as the cleanup is finished.

3 Click OK.

Depending on the size of your document and the number of options selected, 
it may take several seconds to complete the cleanup.
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Formatting the HTML source code in existing documents

The HTML source formatting options that you specify in HTML Format 
preferences and the SourceFormat.txt file apply only to any subsequent new 
documents that you create with Dreamweaver. To apply these formatting options 
to existing HTML documents, use the Apply Source Formatting command.

To apply HTML source formatting options to an existing document:

1 Choose File > Open to open an existing HTML file in the Document window.

2 Choose Commands > Apply Source Formatting.

Cleaning up Microsoft Word HTML
In Dreamweaver, you can open or import documents saved by Microsoft Word 
as HTML files, then use the Clean Up Word HTML command to remove the 
extraneous HTML code generated by Word. The code that Dreamweaver removes 
is primarily used by Word to format and display documents in Word and is not 
needed to display the HTML file. Retain a copy of your original Word (.doc) file 
as a backup, because you may not be able to reopen the HTML document in 
Word once you’ve applied the Clean Up Word HTML feature. The Clean Up 
Word HTML command is available for documents saved as HTML files by 
Word 97 or later.

To clean up Word HTML: 

1 In Microsoft Word, save your document as an HTML file.

2 Open the HTML document in Dreamweaver using either of the 
following methods:

• Choose File > Import > Import Word HTML and select a file to open.

Dreamweaver opens the file and then automatically opens the Clean Up Word 
HTML dialog box.

• Choose File > Open and select a file to open.

An HTML Corrections log file is automatically generated if Warn when Fixing 
or Removing Tags is selected in HTML Rewriting preferences. This is not part 
of the Clean Up Word HTML feature. Click Continue to exit the dialog box. 
Then, in Dreamweaver, choose Commands > Clean Up Word HTML.

3 With either of these methods, there may be a slight delay while Dreamweaver 
attempts to determine which version of Word was used to save the file. If 
Dreamweaver is unable to determine this, select the correct version using 
the pop-up menu. 
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4 Choose which options the Clean Up Word HTML feature should use. The 
Basic tab displays the following options: 

• Remove all Word Specific Markup removes all Word-specific HTML, 
including XML from html tags, Word custom meta data and link tags in the 
head of the document, Word XML markup, conditional tags and their 
contents, and empty paragraphs and margins from styles. You can select each of 
these options individually using the Detailed tab.

• Clean up CSS removes all Word-specific CSS, including inline CSS styles when 
possible (where the parent style has the same style properties), style attributes 
beginning with “mso,” non-CSS style declarations, CSS style attributes from 
tables, and all unused style definitions from the head. You can further 
customize this option using the Detailed tab.

• Clean up <font> Tags removes HTML tags, converting the default body text to 
size 2 HTML text. 

• Fix Invalidly Nested Tags removes the font markup tags inserted by Word 
outside the paragraph and heading (block-level) tags. 

• Set Background Color allows you to enter a hexadecimal value to set the 
background color of your document. If you do not set a background color, 
your Word HTML document will have a gray background. The default 
hexadecimal value set by Dreamweaver is white. 

• Apply Source Formatting applies the source formatting options you specify in 
HTML Format preferences and SourceFormat.txt to the document.

• Show Log on Completion displays an alert box with details about the changes 
made to the document as soon as the cleanup is finished.

5 Click OK.

Depending on the size of your document and the number of options selected, 
it may take several seconds to complete the cleanup. The preferences you 
entered are automatically saved as the default Clean Up Word HTML settings.
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Using external HTML editors
You may want to use a text editor to hand-code large amounts of HTML, 
JavaScript, or VBScript. You can use any external text editor with Dreamweaver, 
including Notepad (bundled with Windows 95 and NT) or SimpleText (bundled 
with the Macintosh), BBEdit, HomeSite, vi, emacs, and TextPad. See “Using an 
external text editor with Dreamweaver” on page 350 and “Using BBEdit with 
Dreamweaver (Macintosh only)” on page 351. 

Using an external text editor with Dreamweaver

You can launch your primary external text editor from Dreamweaver to edit the 
source HTML for the current document and then switch back to Dreamweaver to 
continue editing graphically. Dreamweaver detects any changes that have been 
saved to the document externally and prompts you to reload the document 
upon returning.

If you use BBEdit on the Macintosh, follow the steps in “Using BBEdit with 
Dreamweaver (Macintosh only)” on page 351 instead of the following steps.

To set up external editors for file types other than text and HTML, see 
“Launching an external editor” on page 298.

To choose an external HTML editor:

1 Choose Edit > Preferences, and select File Types/Editors.

2 (Macintosh only) To use an HTML editor other than BBEdit, deselect the 
Enable BBEdit Integration option. To use BBEdit, leave Enable BBEdit 
Integration selected and skip the rest of these steps.

3 Click the Browse button next to the External Code Editor box to choose 
a text editor.

4 In the Reload Modified Files option, specify what you want Dreamweaver to 
do when it detects that changes have been made externally to a document that 
is open in Dreamweaver.

5 In the Save on Launch option, specify whether Dreamweaver should always 
save the current document before launching the editor, never save the 
document, or prompt you to ask whether to save or not each time you launch 
the external editor.

To launch the external HTML editor:

Choose Edit > Edit with (editor name).
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Using BBEdit with Dreamweaver (Macintosh only)

When BBEdit integration is turned on, once you have a document open in 
both BBEdit and Dreamweaver, switching from one application to the other 
automatically updates the document with the latest changes. In addition, 
both programs track the current selection; for example, you can make a 
selection in Dreamweaver and then switch to BBEdit, where the same element 
will be selected. 

You can disable BBEdit integration if you prefer working with an older version of 
BBEdit or a different HTML text editor. Selections are not tracked if BBEdit 
integration is turned off.

To use BBEdit with Dreamweaver:

1 Choose Edit > Edit with BBEdit.

2 Edit the document in BBEdit.

3 Click the Dreamweaver button on the HTML Tools palette in BBEdit to 
return to Dreamweaver.

To disable BBEdit integration:

1 Choose Edit > Preferences, and select File Types/Editors.

2 Deselect Enable BBEdit Integration and click OK.
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Editing ColdFusion and Active Server files in Dreamweaver

Dreamweaver displays icons to identify blocks of ColdFusion Markup 
Language (CFML) or Active Server Pages (ASP) code in the Design 
view whenever possible.

Note: By default, Dreamweaver never rewrites HTML found in ColdFusion and ASP files.

To edit a block of ASP code from the Design view:

1 Click the yellow ASP marker to select it.

2 In the Property inspector, click the Edit button.

3 Edit the ASP code in the dialog box that appears, and then click OK.

To edit a block of CFML code from the Design view:

1 Click the CFML marker to select it.

2 In the Property inspector, do one of the following:

• Click the Attributes button to edit the tag’s attributes and their values or to 
add new ones.

• Click the Content button to edit the content that appears between the opening 
and closing CFML tags. If the selected tag is an empty tag (that is, if it has no 
closing tag), the Content button is disabled.

If you don’t see markers or highlighted text where you know ASP or CFML code 
exists, first make sure that View > Visual Aids > Invisible Elements is enabled. If 
that option is selected and the icons are still not visible, Dreamweaver can’t display 
the code as CFML or ASP. This can happen, for example, when conditionals are 
inserted into HTML tags, as in the following ASP code:

<input type="checkbox" name="month" value="October"
<% if month="October" then %>checked<% end if %>
>

To edit CFML or ASP code in the code editors, do one of the following:

Find the code in the Code view or Code inspector and edit it directly.

To find the CFML or ASP code:

Position the insertion point near the location of the CFML or ASP code in the 
Design view. The CFML or ASP code will be highlighted in the Code view or 
Code inspector and you can edit it directly.

For information about processing CFML or ASP code and viewing the results 
in the Document window, see “Customizing the interpretation of third-party 
tags” on page 537.
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	Chapter 14
	Editing HTML in Dreamweaver
	Although Macromedia Dreamweaver allows you to create and edit Web pages visually without worrying...
	For example, suppose you select text on your document and apply a new font, but it only affects h...
	If you are interested in learning HTML, using the Dreamweaver visual editing capabilities along w...
	Dreamweaver provides access to the HTML code through the Code view, the Code inspector, and the Q...
	Dreamweaver also gives you the ability to open HTML files written elsewhere without worrying abou...
	Understanding basic HTML tags

	It can be useful to have a basic understanding of HTML when using Dreamweaver. You can easily see...
	HTML is a text markup language. This means that HTML documents are plain text documents that have...
	For example, the i tag controls italic text. By placing <i> in your HTML, you tell the browser th...
	Web browsers interpret these tags in your HTML document and display the text with the proper form...
	Structure of a document

	Every HTML document (Web page) must contain certain standard tags—the head tag and body tag. The ...
	Here is the structure of a sample document:
	<html>
	<head>
	<title>Title goes here</title>
	</head>
	<body>
	<center>
	<p>
	<font size=+2>Welcome to my page</font>
	</p>
	<p>
	The p is a paragraph tag, which tells the browser that this is all one paragraph.
	</p>
	</center>
	</body>
	</html>
	The required tags for every HTML document are html, head, and body.
	Head tags

	The head section (surrounded by head tags) contains only the page title (surrounded by title tags...
	The text that you put between <title> and </title> will appear in the top title bar of the browse...
	For example, the following HTML results in the page shown below:
	<html>
	<head>
	<title>Purcy the cat</title>
	</head>
	Body tags

	The body of your document contains the content of your page. All your text, images, tables, and o...
	<html>
	<head>
	<title>Purcy the cat</title>
	</head>
	<body>
	<center>
	<h2>
	Welcome to my home page.
	</h2>
	<p>
	I am a two-year-old part Siamese cat who lives in
	San Francisco with my two owners.
	</p>
	<br>
	<img src="cat.gif" width="400" height="250” align=”center”>
	<br>
	<p>
	I like to eat all kinds of food, especially cheese.
	</p>
	</center>
	</body>
	</html>
	All of the tags in the body section of the example can be used to format your content.
	Heading tags—that is, h1 through h6 tags—mark the text as headings. Headings are typically displa...
	<h1> This is a heading 1</h1>
	Paragraph tags (p) separate your text content into paragraphs. Because Web browsers wrap lines an...
	<p>
	I am a two-year-old Siamese cat who lives in San Francisco with my two owners.
	</p>
	<p>
	I like to eat all kinds of food, especially cheese.
	</p>
	Line break tags (br) force line breaks in your page, rather than adding extra white space like th...
	Line break tags
	Space created by line breaks
	Image tags insert images in your page. An image tag follows the format <img�src="imagefilename">;...
	The following example shows a complete image tag:
	<img src="cat.gif" width="400" height="250” align=”center”>
	Text formatting tags

	You can use HTML source code to format the text in your Web page. For example, you can specify te...
	<b>This text will appear bold in the Web page</b>.
	<i>This text will appear italic in the Web page</i>.
	<font face=”verdana” size=”2”>This text will display with the
	Verdana font face and will be larger than the other text.</font>
	Inserting comments

	A comment is descriptive text that you insert in the HTML code to explain the code or provide oth...
	To insert a comment:
	1 Place the insertion point where you want the comment, either in the Code view (or Code inspecto...
	See “Using the Code view (or Code inspector)” on page 330.
	2 Click the Comment button in the Invisibles category of the Objects panel, or choose Insert�> In...
	Creating a comment generates the following HTML code:
	<!-- Comment text-->
	To display comment markers in the Design view, choose View�> Visual Aids > Invisible�Elements. Ma...
	To add to an existing comment, do one of the following:
	• Select the Comments marker in the Design view and enter text in the Property�inspector.
	• Find the comment in the code (see earlier example) and add text directly to it.
	Using the Dreamweaver Reference panel

	The Reference panel provides you with a quick reference tool for HTML tags, JavaScript objects, a...
	To open the Reference panel:
	1 Select the tag, object, or style in the Code or Design view that you want information about.
	2 Click the Reference button in the toolbar (View > Toolbar) or choose Window�> Reference.
	The Reference panel opens, displaying information about the tag, object, or style that you select...
	The Book pop-up menu displays the name of the book that the reference material comes from: The O’...
	The Tag, Object, or Style (depending on which book you have selected) pop-up menu displays the ta...
	Next to the Tag, Object, or Style pop-up menu is a menu that contains the list of attributes for ...
	About Roundtrip HTML

	Roundtrip HTML is a unique feature in Dreamweaver that lets you move your documents back and fort...
	The following are key features of Roundtrip HTML:
	• By default, Dreamweaver rewrites overlapping tags, closes open tags that aren’t allowed to rema...
	• When Highlight Invalid HTML is turned on, Dreamweaver highlights invalid HTML (that it does not...
	Note: Enable/Disable Invalid HTML Highlighting is only available in the Code view (or Code inspec...
	• Dreamweaver does not change tags that it does not recognize—including XML tags—because it has n...
	• Dreamweaver does not alter ColdFusion Markup Language (CFML) or Microsoft Active Server Pages (...
	• Dreamweaver lets you launch a text-based HTML editor to edit the current document. Dreamweaver ...
	Using the Code view (or Code inspector)

	You can view the HTML source code for the current document in several ways: you can display only ...
	As you add or change content in the Design view, Dreamweaver immediately displays the changes in ...
	Changes or additions that you make in the code appear in the Design view only after you synchroni...
	To synchronize the Code and Design views:
	Click in the Design view after working in a code editor or click the Refresh Design view button i...
	Dreamweaver never rewrites HTML that you type directly into a code editor. If you enter invalid c...
	Opening the Code view (or Code inspector)

	You can view the HTML source code in several ways: by displaying both code and design in the Docu...
	To display both the Code and Design views:
	Choose View > Code and Design, or click the Show Code and Design Views button on the toolbar.
	The HTML code appears in the top pane, and the Design view appears in the�bottom pane.
	You can adjust the size of the panes by dragging the splitter bar.
	To adjust the split Code and Design view, do one of the following:
	• To display the Design view on top, choose View > Design View on Top. Alternatively, select Desi...
	• To view only HTML code in the Document window, choose View > Code or click the Show Code View b...
	• To view only the visual design, choose View > Design or click the Show Design View button in th...
	If you prefer to work with the HTML code in a separate window, use the Code inspector to view you...
	To open the Code inspector, do one of the following:
	• Choose Window > Code inspector.
	• Click the Code Inspector icon in the Launcher bar (in the lower right corner of the Document wi...
	• Press F10.
	To toggle between the Document window and the Code inspector:
	Press Control-Tab (Windows) or Option-Tab (Macintosh).
	Setting Code view (or Code inspector) options

	You can set word wrapping, code indenting, syntax coloring and more from the Options menu in the ...
	To access the Options menu, the Code view (or Code inspector) must be active. Click in the Code v...
	To set Code view (or Code inspector) options:
	1 Access the options by doing one of the following:
	• Click the Options pop-up menu in the toolbar. (Choose View > Toolbar to view the toolbar.)
	• Choose View > Code View Options.
	The options menu is also available at the top of the Code inspector.
	2 Set the options you want:
	• Line Wrap wraps the code so that is viewable without horizontal scrolling. This setting does no...
	• Line Numbers adds line numbers along the side.
	• Highlight Invalid HTML turns on error highlighting. When Highlight Invalid HTML is turned on, D...
	• Syntax Coloring marks the different parts of your code with colors so that you can quickly dete...
	• Auto Indent makes your code indent automatically. To change the indent spacing or tags that aut...
	Writing and editing code

	As you write and edit your code in the Code view (or Code inspector), you can indent specific lin...
	To indent selected code:
	1 Select the line or lines of code you want to indent.
	For indenting to work, the whole line must be selected.
	2 Choose Edit > Indent Code.
	The code will be indented. Choose Edit > Outdent Code to move indented code�back.
	To check for balanced tags:
	1 Place the insertion point in the nested code you want to check.
	2 Choose Edit > Select Parent Tag.
	The enclosing matching tags will be highlighted in your code. Choosing Edit > Select Parent Tag a...
	Inserting scripts

	You can write or insert scripts in the Code view (or Code inspector), or you can enter JavaScript...
	To display script markers in the Document window, choose View > Visual Aids > Invisible Elements....
	To insert a script in code or Design view:
	1 Place the insertion point where you want the script.
	2 Click the Script button on the Objects panel, or choose Insert > Invisible�Tags�> Script.
	3 In the dialog box that appears, choose the scripting language from the Language pop-up�menu.
	If you are using JavaScript and are unsure of the version, choose JavaScript rather than JavaScri...
	4 Enter your script code in the Content text box.
	To link to an external script file:
	1 Follow steps 1 through 3 above.
	2 Click OK without typing anything in the Content text box.
	3 Select the script marker in the Design view of the Document window.
	Choose View�> Visual Aids > Invisible�Elements to view the marker. Make sure that scripts are sel...
	4 In the Property inspector, click the folder icon to browse to and select the external script fi...
	Editing a script

	You can edit a script in a code editor or the Design view.
	To edit the script in the Code view:
	Find the script in the Code view and edit it directly. Selecting the Script marker in the design ...
	To edit the script in the Design view:
	1 Select the Script marker.
	2 In the Property inspector, click the Edit button.
	If you linked to an external script file, the file automatically opens in Code view, where you ca...
	Note: If there is code between the script tags, the Script Properties dialog box will open, even ...
	The following properties appear in the Script Properties dialog box (and the Property inspector) ...
	• Language specifies either JavaScript or VBScript as the language of the script.
	• Type specifies the type of script, either client-side or server-side.
	• Source specifies an externally linked script file. Click the folder icon to choose the file, or...
	• Script is where you edit/write your script.
	To check for balanced braces:
	1 Place the insertion point in the nested code you want to check.
	2 Choose Edit > Balance Braces.
	The enclosing matching tags are highlighted in your code. Choosing Edit > Balance Braces again wi...
	Viewing script functions

	You can view all of the JavaScript or VB Script functions in your code from the Code Navigation p...
	To view the script functions:
	Click the Code Navigation button in the toolbar.
	If your code contains JavaScript or VB Script functions, they will appear in the menu. To see the...
	To go to a function in your code:
	Select a function from the Code Navigation pop-up menu. The function will be highlighted in the C...
	Opening and editing non-HTML files in Dreamweaver

	When you open a non-HTML file (for example, a .js file) in Dreamweaver, Dreamweaver does not alte...
	You can set Dreamweaver to automatically open non-HTML files with certain extensions by default. ...
	To set the default preferences for non-HTML files:
	1 Choose Edit > Preferences, then select File Types/Editors.
	2 In the Open in Code View field, type the file name extensions you want to open automatically in...
	The default file extensions listed are .js, .txt, and .asa. You can add as many�as�you�want.
	Editing an HTML tag in the Design view

	Use the Quick Tag Editor to quickly inspect and edit the HTML source of a single tag from within ...
	The Quick Tag Editor has three modes:
	• Insert HTML, used to insert new HTML code
	• Edit Tag, used to edit an existing tag
	• Wrap Tag, used to wrap a new tag around the current selection
	The current selection in the Design view determines the mode in which the Quick Tag Editor opens....
	If you use any invalid HTML in the Quick Tag Editor, Dreamweaver attempts to�correct it for you b...
	To perform more extensive HTML editing, use the Code view (or Code inspector).
	To open the Quick Tag editor in Insert HTML mode:
	1 Click in the Design view to place the insertion point where you want to�insert�code.
	2 Press Control+T (Windows) or Command+T (Macintosh), or click the Quick�Tag Editor button in the...
	The Quick Tag Editor opens.
	3 Enter the HTML tag, then press Enter.
	The tag is inserted into your code. Press Esc to exit without making any changes.
	To open the Quick Tag editor in Edit Tag mode:
	1 Select the text or object that you are editing in the Design view.
	You can also select the tag you want to edit from the tag selector at the bottom of the Document ...
	2 Press Control+T (Windows) or Command+T (Macintosh), or click the Quick Tag Editor button in the...
	The Quick Tag Editor opens.
	3 Enter new attributes, edit existing attributes, or edit the tag’s name; then�press�Enter.
	The edited tag is inserted into your code. Press Esc to exit without making�any�changes.
	To open the Quick Tag Editor in Wrap Tag mode:
	1 Select unformatted text or an object.
	If you select text or an object that includes an opening or closing HTML tag, the Quick Tag Edito...
	2 Press Control+T (Windows) or Command+T (Macintosh), or click the Quick Tag Editor button in the...
	The Quick Tag Editor opens.
	3 Enter a single opening tag, such as <font="verdana">, and press Enter.
	The tag is inserted at the beginning of the current selection, and a matching closing tag is inse...
	To apply your changes immediately:
	After editing a tag, press Tab or Shift+Tab. The change you made is applied immediately, rather t...
	If you want to prevent this behavior, deselect the Apply Changes Immediately While Editing option...
	Note: When the Apply Changes Immediately While Editing option is deselected, multiple changes tha...
	To cycle through the Quick Tag Editor modes:
	With the Quick Tag Editor active, press Control+T (Windows) or Command+T (Macintosh).
	The Quick Tag Editor changes modes each time you use the keyboard shortcut, cycling among Insert ...
	To move the Quick Tag Editor on the screen:
	Drag the editor’s handle (where the mode name appears).
	Using the hints menu

	While in the Quick Tag Editor, you can access an attributes hint menu that lists all the valid at...
	To see a list of valid attributes for a tag you’re editing:
	Pause for a few seconds while editing an attribute name. A hints menu appears, listing all the va...
	• As you begin to type an attribute name, the hints menu scrolls to highlight the first attribute...
	• To move the highlighting up and down in the menu, use the Up and Down Arrow keys or the scroll ...
	• To choose the highlighted attribute name, press Enter (Windows) or Return (Macintosh). Alternat...
	• To dismiss the hints menu without selecting an entry, press Esc or simply continue typing.
	When you pause while entering or editing a tag name, a similar hints menu appears, listing tag na...
	The tags and attributes that the hints menu displays come from the TagAttributeList.txt file, loc...
	To edit existing attribute values in Edit Tag mode:
	Press Tab to move forward from one item to the next, until the attribute (or tag) that you want t...
	To add a new attribute to a tag:
	1 Use Tab, the arrow keys, and the Spacebar to move the insertion point to where you want to add ...
	2 Type a valid attribute name for the tag.
	If you pause in typing, the hints menu appears.
	Removing a tag

	You can remove a tag from your document, leaving its content (if any) in place.
	To remove a tag:
	1 Do one of the following:
	• Select the tag in the tag selector at the bottom left of the Document window.
	• Select anything in the Document window, or click to place the insertion point in the window.
	2 Right mouse-click (Windows) or Control-click (Macintosh) in the Design view, and choose Remove ...
	Setting Quick Tag Editor preferences

	Quick Tag Editor preferences let you control whether the edits you make in the Quick Tag Editor a...
	Apply Changes Immediately While Editing controls whether your Quick Tag Editor changes are automa...
	Enable Tag Hints controls whether the hints menu appears while you’re typing in the Quick Tag Edi...
	Setting code formatting preferences

	You can set the following preferences for formatting code in Dreamweaver:
	• Code Colors preferences control how HTML tags (and the text between them) and scripts are color...
	• Code Format preferences determine common code formatting options, such as line length and inden...
	• Code Rewriting preferences determine what changes, if any, Dreamweaver makes to your code when ...
	• Fonts/Encoding preferences let you specify the font in which your code appears in the Code view...
	Finally, the SourceFormat.txt file (in the Dreamweaver/Configuration folder) provides precise spe...
	Setting Code Colors preferences

	Use Code Colors preferences to control the background, text, tag, and reserved keyword colors in ...
	Background specifies the background color of the Code view (or Code inspector). This�color appear...
	Text specifies the color of text that appears between tags. For example, in the code�<b>some text...
	Comments specifies the color for comment tags (<!-- -->) and their contents.
	Tag Default specifies the color for all tags except comments. To override this color, set the Tag...
	Reserved Keywords specifies the color for all reserved keywords. To override this color, set the ...
	Other Keywords specifies the color for all other keywords. To override this color, set the Tag Sp...
	Strings specifies the color for all strings in your code. To override this color, set the Tag Spe...
	Tag Specific allows you to override the other color settings by specifying colors for�specific tags.
	To set a color for a specific tag:
	1 Select a tag in the Tag Specific box.
	Shift-click to select adjacent tags. To select nonadjacent tags, Control-click (Windows) or Comma...
	2 Click the radio button next to the color swatch at the bottom of the panel, and use one of thes...
	• Click the color swatch and select a new color from the palette of browser-safe colors or the sy...
	• In the text field next to the swatch, enter a hexadecimal value.
	3 To color the text between the opening and closing tags, select Apply Color to�Tag Contents.
	Setting Code Format preferences

	Use the following Code Format preferences to control code formatting such as indentation, line le...
	Note that all the preferences except Override Case Of affect only new documents and new additions...
	Indent turns on indentation of all tags marked indent in the SourceFormat.txt file. See “Changing...
	Use specifies whether to indent using spaces or tabs.
	Table Rows and Columns automatically indents tr and td tags to make table code easier to read. Th...
	Frames and Framesets automatically indents frame and nested frameset tags to make frameset files ...
	Indent Size determines the size of indents. The size is measured in spaces if Use is set to space...
	Tab Size determines the size of tabs (measured in character spaces).
	Automatic Wrapping adds “hard” returns once a line reaches the specified column width. (Note that...
	Line Breaks specifies the type of remote server (Windows, Macintosh, or UNIX) that hosts your rem...
	Case for Tags and Case for Attributes control the capitalization of tag and attribute names. Thes...
	Override Case Of: Tags and Attributes specify whether to enforce your specified case options at a...
	Centering specifies whether elements should be centered using div align="center" or center. Both ...
	Setting Code Rewriting preferences

	Code Rewriting preferences determine what Dreamweaver does while opening HTML or script documents...
	Fix Invalidly Nested and Unclosed Tags rewrites overlapping tags. For example, <b><i>text</b></i>...
	Remove Extra Closing Tags deletes closing tags that have no corresponding opening tag.
	Warn When Fixing or Removing Tags displays a summary of technically invalid HTML that Dreamweaver...
	Never Rewrite HTML: In Files with Extensions allows you to prevent Dreamweaver from rewriting HTM...
	The two Special Characters options allow you control over whether Dreamweaver encodes certain cha...
	Cleaning up HTML source code

	Use the Clean Up HTML command to remove empty tags, combine nested font tags, and otherwise impro...
	To clean up HTML source code:
	1 Open an existing document and choose Commands > Clean Up HTML.
	2 In the dialog box that appears, select from the following options:
	• Remove Empty Tags removes any tags that have no content between them. For example, <b></b> and ...
	• Remove Redundant Nested Tags removes all redundant instances of a tag. For�example, in the code...
	• Remove Non-Dreamweaver HTML Comments removes all comments that were not inserted by Dreamweaver...
	• Remove Dreamweaver HTML Comments removes all comments that were inserted by Dreamweaver. For ex...
	• Remove Specific Tag(s) removes the tags specified in the adjacent text field. Use this option t...
	• Combine Nested <font> Tags When Possible consolidates two or more font�tags when they control t...
	• Show Log on Completion displays an alert box with details about the changes made to the documen...
	3 Click OK.
	Depending on the size of your document and the number of options selected, it may take several se...
	Formatting the HTML source code in existing documents

	The HTML source formatting options that you specify in HTML Format preferences and the SourceForm...
	To apply HTML source formatting options to an existing document:
	1 Choose File > Open to open an existing HTML file in the Document window.
	2 Choose Commands > Apply Source Formatting.
	Cleaning up Microsoft Word HTML

	In Dreamweaver, you can open or import documents saved by Microsoft Word as�HTML files, then use ...
	To clean up Word HTML:
	1 In Microsoft Word, save your document as an HTML file.
	2 Open the HTML document in Dreamweaver using either of the following�methods:
	• Choose File�> Import > Import Word HTML and select a file to open.
	Dreamweaver opens the file and then automatically opens the Clean Up Word HTML dialog box.
	• Choose File�> Open and select a file to open.
	An HTML Corrections log file is automatically generated if Warn when Fixing or Removing Tags is s...
	3 With either of these methods, there may be a slight delay while Dreamweaver attempts to determi...
	4 Choose which options the Clean Up Word HTML feature should use. The Basic tab displays the foll...
	• Remove all Word Specific Markup removes all Word-specific HTML, including XML from html tags, W...
	• Clean up CSS removes all Word-specific CSS, including inline CSS styles when possible (where th...
	• Clean up <font> Tags removes HTML tags, converting the default body text to size 2 HTML text.
	• Fix Invalidly Nested Tags removes the font markup tags inserted by Word outside the paragraph a...
	• Set Background Color allows you to enter a hexadecimal value to set the background color of you...
	• Apply Source Formatting applies the source formatting options you specify in HTML Format prefer...
	• Show Log on Completion displays an alert box with details about the changes made to the documen...
	5 Click OK.
	Depending on the size of your document and the number of options selected, it may take several se...
	Using external HTML editors

	You may want to use a text editor to hand-code large amounts of HTML, JavaScript, or VBScript. Yo...
	Using an external text editor with Dreamweaver

	You can launch your primary external text editor from Dreamweaver to edit the source HTML for the...
	If you use BBEdit on the Macintosh, follow the steps in “Using BBEdit with Dreamweaver (Macintosh...
	To set up external editors for file types other than text and HTML, see “Launching an external ed...
	To choose an external HTML editor:
	1 Choose Edit > Preferences, and select File Types/Editors.
	2 (Macintosh only) To use an HTML editor other than BBEdit, deselect the Enable BBEdit Integratio...
	3 Click the Browse button next to the External Code Editor box to choose a�text�editor.
	4 In the Reload Modified Files option, specify what you want Dreamweaver to do when it detects th...
	5 In the Save on Launch option, specify whether Dreamweaver should always save the current docume...
	To launch the external HTML editor:
	Choose Edit > Edit with (editor name).
	Using BBEdit with Dreamweaver (Macintosh only)

	When BBEdit integration is turned on, once you have a document open in both�BBEdit and Dreamweave...
	You can disable BBEdit integration if you prefer working with an older version of BBEdit or a dif...
	To use BBEdit with Dreamweaver:
	1 Choose Edit > Edit with BBEdit.
	2 Edit the document in BBEdit.
	3 Click the Dreamweaver button on the HTML Tools palette in BBEdit to return to Dreamweaver.
	To disable BBEdit integration:
	1 Choose Edit > Preferences, and select File Types/Editors.
	2 Deselect Enable BBEdit Integration and click OK.
	Editing ColdFusion and Active Server files in Dreamweaver

	Dreamweaver displays icons to identify blocks of ColdFusion Markup Language�(CFML) or Active Serv...
	Note: By default, Dreamweaver never rewrites HTML found in ColdFusion and ASP�files.
	To edit a block of ASP code from the Design view:
	1 Click the yellow ASP marker to select it.
	2 In the Property inspector, click the Edit button.
	3 Edit the ASP code in the dialog box that appears, and then click OK.
	To edit a block of CFML code from the Design view:
	1 Click the CFML marker to select it.
	2 In the Property inspector, do one of the following:
	• Click the Attributes button to edit the tag’s attributes and their values or to add�new ones.
	• Click the Content button to edit the content that appears between the opening and closing CFML ...
	If you don’t see markers or highlighted text where you know ASP or CFML code exists, first make s...
	<input type="checkbox" name="month" value="October"
	<% if month="October" then %>checked<% end if %>
	>
	To edit CFML or ASP code in the code editors, do one of the following:
	Find the code in the Code view or Code inspector and edit it directly.
	To find the CFML or ASP code:
	Position the insertion point near the location of the CFML or ASP code in the Design view. The CF...
	For information about processing CFML or ASP code and viewing the results in�the Document window,...

