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Designing Page Layout

Page layout is an important part of Web design. The term page layout refers to the 
way your page will look in the browser, such as where a menu or images will go. 
Macromedia Dreamweaver gives you several different ways to create and control 
your Web page layout.   

One common method for creating a page layout is with HTML tables. Tables can 
be difficult to use, however, since they weren’t originally created for Web page 
layout, but for displaying tabular data. 

To simplify the process of using tables for page layout, Dreamweaver provides 
Layout view. In Layout view, you can design your page using tables as the 
underlying structure, but avoid the traditional pitfalls of using tables. For 
example, you can easily draw cells (table cells) onto your page, then customize and 
move the cells where you want them. Your layout can have a fixed width, or it can 
grow to fill the browser window (see “Setting layout width” on page 179).

You can still lay out your pages using tables in the traditional way (see “Using 
Tables to Present Content” on page 183), or lay out pages using layers and 
then convert them to tables (see “Using tables and layers for layout” on page 421). 
However, the Dreamweaver Layout view is the easiest way to set up your 
page layout.

To use Layout view, you must switch out of Dreamweaver Standard view.
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To switch into Layout view:

Choose View > Table View> Layout View or click the Layout View button in 
the Objects panel. 

Show Layout Table Tabs is automatically enabled in Layout View. To turn off the table 
tabs when in Layout View, choose View > Table View > Show Layout Table Tabs.

Note: If you create a table in Dreamweaver Standard view, then switch into Layout 
view, your table will have empty layout cells that you may need to delete before you can 
create new cells.

Layout View icon

Draw Layout Cell icon

Draw Layout Table icon
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About layout cells and tables
When you switch into Layout view, you can add layout cells to your page. These 
cells will help you block out your page layout. For example, you could draw a cell 
along the top of your page to hold a menu, a cell on the right side of the page for 
submenus, and a cell next to it to hold content. It can be useful to think of the 
layout in terms of a grid of rows and columns.

When you create a layout cell on your page, Dreamweaver automatically creates a 
layout table as a container for the cell. A layout cell cannot exist outside of a layout 
table. You can create your page layout using several layout cells within one layout 
table or you can use multiple layout tables for a more advanced layout.

Using multiple layout tables isolates sections of your layout, so that they 
aren’t affected by another section. This is especially useful when the content in 
a layout cell may change and cause the cell to grow. As the cell grows, it affects 
the other cells near it because cells cannot overlap. If you have created your 
layout with multiple layout tables, the rows and columns of one table will not 
affect another table.

You can also nest layout tables (inserting a layout table into an already existing 
layout table). The cells inside a nested table are not constrained by the rows and 
columns of the outer table. See “Drawing a nested layout table” on page 173.
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Drawing layout cells and tables
You can draw layout cells and tables on your page when in Layout view. If you 
create a layout cell first, a layout table will also automatically be inserted to act as a 
container for the layout cell. A layout cell will always be in a layout table. 

Note: The Layout table that is automatically created by Dreamweaver is the width of your 
Document window. You can resize it or make it autostretch as necessary.

To draw a layout cell:

1 Make sure you are in Layout view, then click the Draw Layout Cell button 
in the Layout category of the Objects panel. The mouse pointer will change 
to a plus sign (+).

2 Position the mouse pointer where you want to start the cell on the page, 
then drag to create the layout cell. To create a number of cells without 
clicking the layout cell button each time, hold down Control (Windows) or 
Command (Macintosh).

The cell will appear outlined in blue on your page. Blue is the default outline color 
for layout cells, see “Setting Layout View preferences” on page 182 to change it. 
The size of each cell is displayed in the column header area along the top of the cell. 
For more information about width, see “Setting layout width” on page 179.
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 Your page layout follows a grid with columns and rows, so cells can span several 
rows or several columns, but they can never overlap each other on the page. 
Dreamweaver helps you maintain this structure by automatically snapping new 
cells that you create to existing cells if you draw them near each other (within 8 
pixels). The cells will also automatically snap to the side of the page if you draw 
them close to the edge (within 8 pixels). To temporarily disable snapping, hold 
down Alt (Windows) or Option (Macintosh) while drawing the cell on the page.

This does not mean that all of your cells must be the same size or width. You can 
have cells in the same column that are different widths, or cells in rows that have 
different heights.
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To draw a layout table:

1 Make sure you are in Layout view, then click the Draw Layout Table button 
in the Layout category of the Objects panel. The mouse pointer will change 
to a plus sign (+).

2 Position the mouse pointer on the page, then click and drag your mouse to 
create the layout table. If it is the first table you have drawn on the page, it will 
automatically be positioned at the top left corner of your page. 

To create a number of tables without clicking the layout table button each 
time, hold down Control (Windows) or Command (Macintosh).

The table will appear outlined in green on your page. Green is the default outline 
color for layout tables, see “Setting Layout View preferences” on page 182 to 
change it. A Layout Table tab also appears at the top of each table you draw and 
helps you distinguish and select the table. The size of each table is displayed in the 
Column Header area along the top of the table. 

For more information about width, see “Setting layout width” on page 179.

Tables cannot overlap each other. Your page layout follows a grid with columns 
and rows, so tables can span several rows or several columns, but they can never 
actually overlap on the page. Dreamweaver helps you maintain this structure by 
automatically snapping new tables that you create to existing tables or cells if you 
draw them near each other (within 8 pixels). The tables will also automatically 
snap to the side of the page if you draw them close to the edge (within 8 pixels). 
To turn off snapping, hold down Alt (Windows) or Option (Mac) while drawing 
the table on the page.

You can create layout tables into empty areas of your page layout, into an existing 
layout table (nesting), or around existing layout cells and tables. When you create 
a Layout table in a blank document, it will automatically snap to the upper left 
corner of your Document window. 

Note: If your page already contains content, a layout table can only be drawn below the 
bottom of the content.

To draw a layout table around existing tables or cells:

1 Make sure you are in Layout view, then click the Draw Layout Table button 
in the Layout category of the Objects panel. The mouse pointer will change 
to a plus sign (+).

2 Click and drag your mouse around existing layout cells or tables. The layout 
table will enclose the existing cells or tables.
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Drawing a nested layout table

You can draw a layout table in an already existing layout table (this creates a nested 
table). The cells inside a nested table are not constrained by the rows and columns 
of the outer table. You can insert multiple nested tables.

To draw a nested table:

1 Click the Draw Layout Table button in the Layout category of the Objects 
panel. The mouse pointer will turn into a plus sign (+).

2 Position the mouse pointer inside the gray space of an existing layout table, 
then click and drag your mouse to create the nested layout table.

A nested layout table cannot be larger than the table that contains it.
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Using the Dreamweaver grid

You can turn on the Dreamweaver grid to use as a guide when you draw your 
layout. You can also have your layout automatically snap to the grid, and change 
the grid or control the snapping behavior by specifying grid settings.

To show or hide the grid in the Document window:

Choose View > Grid > Show Grid or select Grid from the Options drop-down 
menu on the toolbar. 

To change grid settings:

1 Click View > Grid > Edit Grid to open the Grid Settings dialog cell.

2 Do any of the following:

• Click the arrow next to the color swatch and select a color from the palette or 
type the hexadecimal number in the cell. This controls the color of the grid lines.

• Select Show Grid to show the grid in the Document window.

• Select Snap to Grid to enable snapping.

• Type the amount of spacing you want and select Pixels, Inches, or Centimeters 
from the pop-up menu. This controls how far apart the grid lines will appear.

• Choose lines or dots for the grid lines.

3 Click Apply to view the changes, then OK to close the dialog box.

Adding content to a cell

You can add text, images, and other media to layout cells in Layout view just as 
you would in Dreamweaver normal display (Standard view). Click in the cell 
where you want to insert content, then type text or insert other files.

Content can only be inserted into a layout cell, so you must create the layout cells 
first (see “Drawing layout cells and tables” on page 170). The gray spaces in your 
page indicate areas that are not available for adding content, unless you insert a 
layout cell there.

A layout cell expands automatically as you add material that is larger than the cell. 
As the cell expands, surrounding cells may also be affected, and the column that 
the cell is in will also expand.
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To add text to a cell:

Click in the layout cell where you want to add text and do one of the following:

• Type text into the cell. The cell will automatically expand as you type.

• Paste text copied from another document. Use the Paste command. For more 
information, see “Inserting text and objects” on page 234.

To add an image to a cell:

1 Click in the layout cell where you want to add the image.

2 Click the Insert Image button in the Objects panel, choose Insert > Image, or 
drag the Insert Image button from the Objects panel to the page.

3 In the Select Image dialog box, select an image file.

For more information, see “Setting image properties” on page 269.

Clearing automatic cell heights

After you insert content into your cells, you can clear the cell heights to remove 
the setting. Dreamweaver automatically creates the cells with a specified height, 
but once you add content to the cell, you no longer need the specified height.

To clear heights, do one of the following:

• Select Clear Cell Heights from the Column Header menu. The heights are 
cleared and some rows may shrink.

• Select a layout table (click the table tab or edge), then click the Clear Row 
Heights button in the Property inspector. 
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Moving and resizing layout cells and tables
Every cell and table in your layout can be moved or resized, which makes it easy to 
adjust your page layout. To use the Dreamweaver grid as a guide while you move 
or resize your cells and tables, see “Using the Dreamweaver grid” on page 174.

To resize a cell:

1 Click the cell edge or hold down Control (Windows) or Command (Mac) and 
click anywhere in the cell.

Selection handles will appear around the cell.

2 Use the selection handles to drag the cell to your chosen size.

The cell will automatically snap to existing cells (when within 8 pixels of their 
borders). A layout cell cannot overlap other cells and you cannot resize it outside 
the boundaries of its layout table. A layout cell is always at least as large as the 
content it contains.

To move a cell:

1 Click the cell edge.

2 Drag the cell where you want it on the page or use the arrow keys. The arrow key 
moves it 1 pixel at a time, holding down Shift will move it 10 pixels at a time.

To resize a table:

1 Click the table tab. 

Selection handles will appear around the layout table.

2 Use the selection handles to drag the table to your chosen size.

The table will automatically snap to existing cells and tables (when within 8 pixels 
of the existing cell). The layout table cannot be resized so that it will be smaller 
than the boundary of the cells it contains. It also cannot be resized so that it will 
overlap surrounding tables or cells. 

To move a table:

1 Click the table tab.

2 Drag the table where you want it on the page or use the arrow keys. The arrow 
key moves it 1 pixel at a time, holding down Shift will move it 10 pixels at a time.
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Formatting layout cells and tables
You can change the appearance of any layout cell or table in the Property Inspector. 

Formatting a layout cell

You can set content alignment, width and height, and background colors in the 
Property inspector. 

To format a layout cell in the Property inspector:

1 Click the cell edge or hold down Control (Windows) or Command (Mac) and 
click anywhere in the cell.

2 Choose Window > Properties to open the Property inspector.

3 Choose from the following appearance options:

• To change the width, choose Fixed and type a width in pixels in the box, or 
choose Autostretch (see “Setting layout width” on page 179).

• To change the height, specify the height in pixels in the text box.

• To set a background color for the layout cell, choose a color from the 
Bg drop-down color picker or type the hexadecimal code for the color 
you want in the text box.

• To set the horizontal alignment, select from the Horz pop-up menu. You 
can set the alignment of the layout cell’s contents to either Left, Center, 
Right, or Default. 

• To set the vertical alignment, select from the Vert pop-up menu. You can set 
the alignment of the layout cell’s contents to either Top, Middle, Bottom, 
Baseline, or Default. 

• Select No Wrap to prevent word wrapping. If selected, the layout cell widens 
to accommodate all the content, without breaking to a new line.
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Formatting layout tables

You can set width and height, padding and spacing, and more in the 
Property inspector.

To format a layout table:

1 Click the table tab or edge.

2 Choose Window > Properties to open the Property inspector.

3 Choose from the following appearance options:

• To change the width, choose Fixed and type a width in pixels in the box, or 
choose Autostretch (see “Setting layout width” on page 179).

• To change the height, specify the height in pixels in the text field.

• To set cell padding, specify the number of pixels in the CellPad field. Cell 
padding is the amount of space between the content of a layout cell and the cell 
boundary (or wall). When you set this above 0, all the layout cells in the layout 
table you have selected will have this spacing. If you see two numbers appear in 
the column header area, use the Make Widths Consistant option below.

• To set cell spacing, specify the number of pixels in the CellSpace text field. Cell 
spacing is the amount of space between each layout cell. When you set this 
above 0, all the layout cells in the layout table you have selected will have this 
spacing.  If you see two numbers appear in the column header area, use the 
Make Widths Consistant option below.

• To clear the height settings for all the cells in the layout table you selected, click 
the Clear Height Attributes button. If there are no elements in the table, the 
table will collapse completely.

• If you have fixed-width cells in your layout, click the Make Widths Consistent 
button. This automatically resets the HTML widths of each cell to match the 
content within that cell. For example, if you set the width to 200 pixels, then 
added content that stretches the width to 250, you will see these two numbers 
displayed in the top bar of the table: 250 in quotes and 200 in parentheses. 
Clicking Make Widths Consistent removes the 200-pixel setting and keeps 250. 

• To remove spacer images (transparent images that are used to control the 
spacing in your layout) from your layout table, click the Remove All Spacers 
button. (For more information, see “Using spacer images” on page 181).

• If the layout table you selected is nested within another layout table, click 
Remove Nesting to remove the nested layout table without losing any of its 
contents. The layout table will disappear and the layout cells and their contents 
will become part of the parent table.
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Setting layout width
There are two types of widths you can use in Layout view: Fixed width and 
Autostretch. The width appears in the column header area at the top of each 
column. Fixed width is a specific numeric width, such as 300 pixels, and is 
displayed as a number. Autostretch sets the width to resize automatically 
depending on the window size and is displayed as a wavy line. With autostretch, 
your layout always fills the browser window, no matter what size window the 
viewer has set. Although fixed width is the default setting, you’ll typically set some 
of your layout cells or tables to be fixed width and one to be autostretch. The 
settings you specify affects all the cells or tables in that column. Only one column 
in a layout can be autostretch.

For example, suppose your layout has a menu bar on the left side of the page, the 
title at the top, and the main content area on the right. You might set the left 
column to a fixed width and the main content area to autostretch.
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To set autostretch width, do one of the following:

• Go to the top of the column that you want to set to autostretch and select 
Make Column Autostretch from the Column Header menu. Only one column 
can be autostretch.

• Select the column, then click Autostretch in the Property inspector.

When you set a column to autostretch, Dreamweaver will insert spacer images in 
the fixed width columns to control the layout. A spacer image is a transparent 
image that is not visible in the browser window, but is used to control spacing. See 
“Using spacer images” on page 181 for more information.

To set fixed width, do one of the following:

• Go to the top of the column that you want to make a fixed width and select 
Make Column Fixed Width from the column header menu. 

Make Column Fixed Width automatically sets the width of the column to 
match the width of the content in that column.

• In the Property inspector, click Fixed and type a numeric value.

If you enter a numeric value that is less than the width of your content, 
Dreamweaver will automatically set the width to the correct pixel size.

Sometimes two numbers will appear in the Column Header menu: the actual 
width of the column and the width that appears in the HTML code. This can 
happen for a variety of reasons, such as inserting content that is wider than the 
width you drew or specified. It is good practice to make the widths consistent, so 
that only one number appears.

To make the width consistent (so only the actual width is specified):

Select Make Cell Widths Consistent from the column header menu.
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Using spacer images

A spacer image is a transparent image that does not show in the browser window, 
but is used to control spacing in autostretch tables. The spacer image maintains 
the width you set for each table and cell on the page. If you choose not to use 
spacer images in autostretch tables, columns will change size or even visually 
disappear completely if they do not contain content. 

You can insert and remove spacer images in each column or let Dreamweaver add 
them automatically when creating an autostretch column. Columns that contain 
spacer images have a double bar along the top.

When you insert a spacer image in a column or set a column to autostretch, a 
dialog box appears that asks how you want to set up your spacer image file. If you 
have already set a spacer image for the site in the Dreamweaver preferences, the 
dialog box does not appear. See “Setting Layout View preferences” on page 182.

To set up your spacer image:

1 Set a column to autostretch or choose Add Spacer Image from the 
Column Header menu. 

2 In the dialog box that appears, choose from the following options:

• Tell Dreamweaver where to create the spacer image file: If you select this option 
and click OK, another dialog box appears to let you navigate to the directory in 
your site where you would like to store the spacer image file, such as an images 
folder. This is the recommended choice.

• Browse to an existing spacer image file: If you have already created a spacer 
image file for your site, choose this option and then navigate to your spacer 
image in the next dialog box that appears. The spacer image should be a 1 pixel 
by 1 pixel transparent GIF.

• Turn off spacer images for autostretch columns: If you select this option, a 
dialog box appears that warns you that the other columns in your layout may 
collapse to a small width. When you choose not to use spacer images, the 
widths of your columns will be as small as the content in them. Columns 
without content will collapse to nothing. The spacer images help maintain the 
structure of your layout as you originally drew it.

You can insert and remove spacer images in specific columns or remove all spacer 
images in the page.
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To insert a spacer image into a column:

Select Add Spacer Image from the column header menu. The spacer image will be 
inserted into the column. You will not see the image, but the column may shift 
slightly and a double bar will appear at the top.

To remove a spacer image from a column:

Select Remove Spacer Image from the column header menu. The spacer image 
will be removed and the column may shift. 

To remove all spacer images from your page:

Select Remove all Spacer Images from the column header menu or click the 
Remove all Spacers button in the layout table Property inspector. Your whole 
layout may shift slightly or dramatically depending on your content. If there is no 
content in some columns, the columns may disappear completely.

Setting Layout View preferences
Use the Layout View category in the Preferences to set or change spacer image files 
and locations, as well as the colors that Layout view uses to draw the tables and 
cells, and so on.

To open Layout view preferences:

Choose Edit > Preferences, then select Layout View from the Category list.

Autoinsert Spacers specifies whether or not Dreamweaver should automatically 
insert spacer images when you make a column autostretch.

Spacer Image sets the spacer image file for your sites. Choose a site from the drop-
down menu and then create a new image spacer or browse to an existing image 
spacer in that site.

Cell Outline sets the color used to draw the cell outline.

Cell Highlight sets the color that highlights the cell when you move the mouse over 
or choose a cell.

Table Outline sets the color used to draw the table outline.

Table Background sets the background color of the Document window.
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	When you set a column to autostretch, Dreamweaver will insert spacer images in the fixed width co...
	To set fixed width, do one of the following:
	• Go to the top of the column that you want to make a fixed width and select Make Column Fixed Wi...
	Make Column Fixed Width automatically sets the width of the column to match the width of the cont...
	• In the Property inspector, click Fixed and type a numeric value.
	If you enter a numeric value that is less than the width of your content, Dreamweaver will automa...
	Sometimes two numbers will appear in the Column Header menu: the actual width of the column and t...
	To make the width consistent (so only the actual width is specified):
	Select Make Cell Widths Consistent from the column header menu.
	Using spacer images

	A spacer image is a transparent image that does not show in the browser window, but is used to co...
	You can insert and remove spacer images in each column or let Dreamweaver add them automatically ...
	When you insert a spacer image in a column or set a column to autostretch, a dialog box appears t...
	To set up your spacer image:
	1 Set a column to autostretch or choose Add Spacer Image from the Column�Header menu.
	2 In the dialog box that appears, choose from the following options:
	• Tell Dreamweaver where to create the spacer image file: If you select this option and click OK,...
	• Browse to an existing spacer image file: If you have already created a spacer image file for yo...
	• Turn off spacer images for autostretch columns: If you select this option, a dialog box appears...
	You can insert and remove spacer images in specific columns or remove all spacer images in the page.
	To insert a spacer image into a column:
	Select Add Spacer Image from the column header menu. The spacer image will be inserted into the c...
	To remove a spacer image from a column:
	Select Remove Spacer Image from the column header menu. The spacer image will be removed and the ...
	To remove all spacer images from your page:
	Select Remove all Spacer Images from the column header menu or click the Remove all Spacers butto...
	Setting Layout View preferences

	Use the Layout View category in the Preferences to set or change spacer image files and locations...
	To open Layout view preferences:
	Choose Edit > Preferences, then select Layout View from the Category list.
	Autoinsert Spacers specifies whether or not Dreamweaver should automatically insert spacer images...
	Spacer Image sets the spacer image file for your sites. Choose a site from the drop- down menu an...
	Cell Outline sets the color used to draw the cell outline.
	Cell Highlight sets the color that highlights the cell when you move the mouse over or choose a c...
	Table Outline sets the color used to draw the table outline.
	Table Background sets the background color of the Document window.

